Office 365 Delivery Issues

Incident Report for SMX Secure Cloud Solutions

Resolved

This issue has now been resolved.
Posted 8 months ago. Aug 01, 2024 - 14:24 NZST

Identified

We are aware of an incident affecting Microsoft 365 services this morning, including email services (Exchange Online). Currently, we are not seeing any impact or delays to message delivery in or out of Microsoft 365 for SMX customers. For further details, refer to the Microsoft 365 status page at https://portal.office.com/servicestatus. SMX will continue to monitor this incident and provide updates as appropriate.
Posted 8 months ago. Aug 01, 2024 - 10:45 NZST
This incident affected: Mail Filtering.