Microsoft Office 365 emails queued

Incident Report for SMX Secure Cloud Solutions

Resolved

This issue has now been resolved and queued emails will have been delivered.
Posted May 22, 2025 - 21:01 NZST

Identified

Some customers who are using Office 365 with SMX may see their emails queuing at present. This has been raised with Microsoft who have advised there is an issue at present with the Office 365 server. They are working to resolve this as soon as possible. Further updates and information will be posted here once they become available.
Posted May 22, 2025 - 17:39 NZST
This incident affected: Mail Filtering.