Phoneline
Incident Report for SMX Secure Cloud Solutions
Resolved
This incident has been resolved.
Posted Apr 24, 2020 - 15:51 NZST
Investigating
There is currently an issue with our phone line with calls going to voicemail. We are working to resolve this as quickly as possible. We are monitoring our emails for any urgent issues. We apologise for any inconvenience caused.
Posted Apr 23, 2020 - 12:48 NZST
This incident affected: Phoneline.